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O

This ebook is designed as a step-by-step practical guide for beginners,

especially students, who want to learn how to build a simple and

functional database system using Microsoft Access. It provides clear

instructions, real-life examples, and practical exercises to help readers

develop essential database skills.

Readers will learn the fundamental concepts of database design and

understand the importance of organizing data effectively. The guide

introduces Microsoft Access as an easy-to-use tool for creating databases

without advanced programming skills.

Throughout this guide, readers will be guided through a hands-on project

— designing and building a Student-Course Management System. This

project allows users to create and manage tables, build relationships,

develop user-friendly forms, run queries and generate reports for

decision-making.

By the end of this ebook, readers will be able to:

Understand the basic components of a database system.

Create and design tables with appropriate field data types.

Establish relationships between tables.

Design forms for easy data entry.

Perform queries to search, filter, and analyze data.

Generate reports.

This ebook is perfect for students, beginners and anyone looking to

develop practical database skills using Microsoft Access.
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1

Microsoft Access is a powerful and user-friendly database management system

that enables users to create, store, and manage data efficiently.

This eBook provides a step-by-step guide to designing a simple database system,

covering essential components such as tables, forms, queries, and reports. 

By the end of this guide, you will be able to build a fully functional database

system to manage real-world data.

1.0 INTRODUCTION

Table
s

Forms
Queries

Reports
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IMAGE AR

Microsoft Access is a relational database management system

(RDBMS) that allows users to store, retrieve, and manipulate data.

It is commonly used for small to medium-scale applications,

offering features such as tables, forms, queries, reports, and

automation tools.

2.0 GETTING STARTED WITH MICROSOFT
ACCESS

2.1 What is Microsoft Access?

2.2 Advantages of Using Microsoft Access

2

2.3 Microsoft Access layout

Scan to discover Microsoft Access layout with AR
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3.0 PLANNING YOUR DATABASE SYSTEM

3.1 Key Components of Microsoft Access

3.2 Defining the Purpose of Your Database

To understand how to build a system in Access, it is essential to familiarize yourself

with its core components:

3
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A practical example used in this guide:

Store student details

Manage course enrollments

Track student grades

Generate reports

3.0 PLANNING YOUR DATABASE SYSTEM

3.3 Designing a Simple Database System: The Student Management System

Scenario

You are tasked with developing a Student Management System using

Microsoft Access. The system should store student information, track
their courses, and generate reports on student performance.

Your database should allow users to:

1.Store student details (e.g., name, age, contact details, etc.).

2.Manage course enrollment (which students are enrolled in which

courses).

3.Record student grades for each enrolled course.

4.Retrieve specific information using queries.

5.Generate reports summarizing student records and performance.



Table Name Fields Description

Students StudentID (PK), 
FirstName, 

LastName, 

DOB, 

Gender, 

Address,

ContactNumber, 

Email

Stores student personal details

Courses CourseID (PK), 
CourseName,
 CourseCode,
 Instructor

Stores course information

Enrollment EnrollmentID (PK), 
StudentID (FK), 
CourseID (FK), 
EnrollmentDate

Tracks which student is enrolled in
which course

Grades GradeID (PK), 
StudentID (FK), 
CourseID (FK),
 Grade

Stores students' grades

53.0 PLANNING YOUR DATABASE SYSTEM

For this task, we need to create four(4) tables:

(PK = Primary Key, FK = Foreign Key)

IMAGE AR 
(PRIMARY KEY )

IMAGE AR 
(FOREIGN KEY )

Scan to discover definition of Primary Key and Foreign Key with AR 



1. Students ↔ Enrollment
One-to-Many Relationship
A single student can enroll in multiple courses, but each enrollment
record belongs to only one student.
Primary Key: StudentID (Students)
Foreign Key: StudentID (Enrollment)

2. Courses ↔ Enrollment
One-to-Many Relationship
A single course can have multiple students enrolled in it, but each
enrollment entry links to only one course.
Primary Key: CourseID (Courses)
Foreign Key: CourseID (Enrollment)

3. Students ↔ Grades
One-to-Many Relationship
A student can receive multiple grades (one per enrolled course), but
each grade entry is assigned to a single student.
Primary Key: StudentID (Students)
Foreign Key: StudentID (Grades)

4. Courses ↔ Grades
One-to-Many Relationship
A course can have multiple students with different grades, but each
grade entry corresponds to a single course.
Primary Key: CourseID (Courses)
Foreign Key : CourseID (Courses)

5. Enrollment ↔ Grades
One-to-One Relationship
Each enrollment record should correspond to a grade record to track the
student’s performance in that course.
Primary Key: EnrollmentID (Enrollment)
Foreign Key: EnrollmentID (Grades)

3.0 PLANNING YOUR DATABASE SYSTEM

We need to identify the relationship between the tables. Here are the

relationships between the tables:

Relationships Between Tables:

6
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Data Type Description Example

Short Text Stores alphanumeric characters
(letters, numbers, symbols) with
a maximum length of 255
characters.

Names, phone numbers,
addresses

Long Text Stores large amounts of text (up
to 64,000 characters).

Comments, descriptions,
notes

Number Stores numeric values used in
mathematical calculations.

Age, quantity, product
stock

Large Number Stores very large numeric values
(available in .accdb format).

Scientific calculations,
financial data

Date/Time Stores date and time values. Birthdate, meeting time

Currency Stores monetary values with
currency formatting.

Salary, product price

AutoNumber Generates a unique number
automatically for each record.

Customer ID, Order ID

74.0 CREATING TABLES

4.1 Understanding Data Types

When designing tables in Microsoft Access, it's essential to assign a
data type to each column. The Short Text data type is a common choice

since it allows the entry of letters, numbers, and symbols. However,

selecting the appropriate data type enhances database functionality,

enabling features like data validation and built-in functions while

ensuring greater accuracy in stored information. 

The following table provides an overview of the data types available in

Access desktop databases (.accdb and .mdb).



Data Type Description Example

Yes/No Stores Boolean values
(True/False, Yes/No, On/Off).

Active status,
subscription
confirmation

OLE Object Stores objects like images, Word
documents, and Excel
spreadsheets.

Employee photos,
scanned documents

Hyperlink Stores clickable links to
websites, email addresses, or
file locations.

Website URLs, email
contacts

Attachment Allows files (images, PDFs,
documents) to be attached to
records.

Product images, scanned
receipts

Calculated Stores values derived from a
calculation based on other fields

Total price = Quantity ×
Unit Price

84.0 CREATING TABLES



94.0 CREATING TABLES

Data Types



104.0 CREATING TABLES



4.0 CREATING TABLES 11

CREATING TABLE

4.2 Basic Creating Tables in Microsoft Access with AR 

4.3 Creating Tables in Microsoft Access

To understand how to build a system in Access, it is essential to familiarize yourself

with its core components:



STEP 1 Create the "Students" Table

4.0 CREATING TABLES

1.  Open Microsoft Access and create a Blank Database.

2.  Click Table Design to create a new table.

3. Define the fields as follows:

4. Set Student_ID as the Primary Key (Right-click → Primary Key).

12



3. Set Course_ID as the Primary Key. (Right-click → Primary Key).

4. Click Save, name the table Courses, and close it.

4.0 CREATING TABLES

5. To save your Table, click the Save button on the Quick Access
Toolbar or right click on the report’s tab > select Save. When
prompted, enter a name for your table and then click OK. For
this table, name the table as  Students and close it.

STEP 2 Create the "Courses" Table

1.  Open Table Design View.
2.  Define the fields as follows:

13



3. Set EnrollmentID as the Primary Key. (Right-click → Primary Key).

4. Now, we want to set the Student_ID and Course_ID as Foreign Keys by:

Clicking on the Lookup tab under Field Properties.

Choosing Display Control → Combo Box to allow selection from Students and

Courses tables.

144.0 CREATING TABLES

STEP 3 Create the "Enrollment" Table

1.  Open Table Design View.

2.  Define the fields as follows:

5.Click Save, name the table Enrollment, and close it.

STEP 4 Create the "Grades" Table

1.  Open Table Design View.

2.  Define the fields as follows:

3. Set GradeID as the Primary Key. (Right-click → Primary Key).

4. Now, this time, we want to set Student_ID and Course_ID as Foreign Keys using

the Lookup Wizard.



4.0 CREATING TABLES

In the Data Type column for Student_ID field, click the dropdown and

select Lookup Wizard.

In the Lookup Wizard, select “I want the lookup field to get the values
from another table or query.” Click Next.

15



Choose the table that contains Student_ID (e.g., Students Table). Click

Next.

4.0 CREATING TABLES

Select Student_ID as the field to be used for the lookup. Click Next.

16



4.0 CREATING TABLES

Optionally, adjust sorting order and column width. Click Next.

Choose whether to store just the ID number or show additional fields
(e.g., Student Name). Click Next.

Click Finish to complete the setup.

Repeat the same steps for Course_ID, selecting values from the Courses
Table.

17



184.0 CREATING TABLES

STEP 5 Establish Relationships Between Tables

  5. Click Save, name the table Grades, and close it.

  6. Open the Datasheet View of your table and check that the lookup fields work  

       correctly by selecting values from the dropdown.

Now, Student_ID and Course_ID are Foreign Keys referencing the Students
Table and Courses Table, respectively. 

Click on Database Tools → Relationships.

Add the Students, Courses, Enrollment, and Grades tables



Check Enforce Referential Integrity and click Create.

4.0 CREATING TABLES

Check Enforce Referential Integrity and click Create.

Drag Student_ID from the Students table to StudentID in the Enrollment
table (One-to-Many).

Click Save to store the relationships

Drag Course_ID from the Courses table to CourseID in the Enrollment table
(One-to-Many).

Drag Student_ID from the Students table to StudentID in the Grades table
(One-to-Many).

Drag Course_ID from the Courses table to CourseID in the Grades table   (One-

to-Many).

19
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Method 1: Using the Form Wizard

5.0 DESIGNING FORMS FOR DATA ENTRY

5.1 Importance of Forms

Creating forms in your database helps to make data entry easier and

more user-friendly. Forms can be customized and designed to suit

the structure of your database and to provide a clear and organized

way for users to input information.

STEP 1
Create a Form for Student Details

This form will allow users to enter and view student information.

1.Open Microsoft Access and go to the Navigation Pane.

2.Select the Students Table (which contains fields like StudentID, Name, Contact

Number etc).

3. Click on the Create tab in the ribbon and click Form Wizard.

20

5.2 Creating Forms for the Student Management System



5.0 DESIGNING FORMS FOR DATA ENTRY

4. In the wizard, select all fields from the Students Table and click Next.

5. Choose a layout (e.g., Columnar) and click Next.

21



5.0 DESIGNING FORMS FOR DATA ENTRY

6. Name the form (e.g., Student Form) and click Finish.

Now, your STUDENT FORM is created and opened in Form View

22



235.0 DESIGNING FORMS FOR DATA ENTRY

CREATING FORM

Scan to discover the step-by-step guide to creating a form with AR



Method 2: Using the Form Design View

5.0 DESIGNING FORMS FOR DATA ENTRY

1.Go to the Create Tab → Click  Form Design.

2. Click Add Existing Fields in the ribbon, then drag the fields from the Students
Table onto the form.

24



4. To save your form, click the Save button on the Quick Access Toolbar or right click

on the form’s tab > select Save. When prompted, enter a name for your form and

then click OK. In this practical, you can save the form as Student Form.

255.0 DESIGNING FORMS FOR DATA ENTRY

3. Use the Design Tools to arrange labels and fields neatly.

STEP 2
Create a Form for Course Enrollment

This form will allow users to enroll students in courses.

1.Select the Enrollments Table (which includes StudentID, CourseID, and

EnrollmentDate).

2.Go to Create > Form Wizard.

3.Choose all fields from the Enrollments Table and click Next.

Using the Form Wizard



5. Name the form as Enrollment Form and click Finish.

5.0 DESIGNING FORMS FOR DATA ENTRY

4. Select a Tabular or Columnar layout and click Next.

26



5.0 DESIGNING FORMS FOR DATA ENTRY

To add a Combo Box for StudentID:

1.Open the Enrollment Form in Design View.
2.Right click on StudentID Field, then go to Properties.

27



5.0 DESIGNING FORMS FOR DATA ENTRY

   3. On the Property Sheet, Set the Row Source to STUDENTS.

4. Save the changes.

5. Repeat for CourseID (using the Courses Table).

28



1.  Select the Grades Table (which includes StudentID, CourseID, and Grade).

2.  Click on the Create tab in the ribbon and click Form Wizard.

3.  Choose all fields from the Grades Table and click Next.

5.0 DESIGNING FORMS FOR DATA ENTRY

STEP 3
Create a Form for Recording Student Grades

This form will allow users to enter student grades for each course.

29



4. Select a Datasheet or Columnar Layout and click Next.

5.0 DESIGNING FORMS FOR DATA ENTRY

5. Name the form as Student Grades Form and click Finish.

30



6. Open the form in Design View and adjust the layout as needed.

5.0 DESIGNING FORMS FOR DATA ENTRY

Method 3: Using the Form Command

STEP 4
Create a Form for Registering the Courses

This form will allow users to register courses and instructor for each courses.

1.  Select the Courses Table 
2.Click on the Create tab in the ribbon and click Form command.

31



3.Now, your COURSES FORM is created and opened in Layout View. Save the form as

COURSES FORM.

5.0 DESIGNING FORMS FOR DATA ENTRY 32



335.0 DESIGNING FORMS FOR DATA ENTRY

5.3 Modifying Your Form

Once a form is created in Microsoft Access, you may want to

customize it to improve its functionality and appearance.

Modifying forms not only enhances the user experience but

also ensures your database system looks professional and is

easy to navigate.

This chapter will guide you through the step-by-step process of

modifying a form, including adjusting layouts, adding buttons

and images, and applying consistent formatting.

STEP 1
Open the Form in Design or Layout View

1.Go to the Navigation Pane and right-click on the form you wish to modify.

2.You can use Design View if you want full control over your form, or try Layout
View for quick and easy formatting

3.In this practical, we will begin by opening the Student Form in Layout View.



345.0 DESIGNING FORMS FOR DATA ENTRY

STEP 2
Rearrange or Resize Fields

1.Click on any field (e.g., Name or Contact Number) to select it.

2.Drag the field to a new position or use the resize handles to adjust its size.

3.Use Ctrl + Click to select multiple fields for group movement.

Using the Property Sheet to Resize Fields

The Property Sheet in Microsoft Access allows you to fine-tune form controls,

including the size of text boxes and other fields

If the Property Sheet is not already visible:

Go to the Design tab and click on Property Sheet in the Tools group.



355.0 DESIGNING FORMS FOR DATA ENTRY

Click on the text box or control you wish to resize (e.g., the DOB field).

The Property Sheet will update to show the properties of the selected control.



365.0 DESIGNING FORMS FOR DATA ENTRY

In the Property Sheet, go to the Format tab to adjust the size of the DOB text box

Locate the Width and Height properties.

Enter specific values (e.g., 5cm or 2"), or use the arrow buttons to increase/decrease

the size incrementally.

Example :-

STEP 3
Edit Title or Heading

Right-click on the form tab and select Design View.



375.0 DESIGNING FORMS FOR DATA ENTRY

STEP 4
Add Buttons for Navigation or Actions 

Access forms come with default navigation buttons, but adding

your own makes the form easier to use—especially for beginners.

Custom buttons guide users clearly, simplify the interface, and

give your form a cleaner, more polished, app-like feel.

Now, we will add command buttons to the Student form to make

it easier to navigate and perform common tasks

A default title (e.g., "Student Form") will appear at the form header.

Click on it to edit the text (e.g., change it to "Student Information").

 Add a “Next Record” Button
Click the Design tab on the Ribbon.

In the Controls group, click the Button tool.



385.0 DESIGNING FORMS FOR DATA ENTRY

Click on the form where you want the button to appear.

The Command Button Wizard will open.



395.0 DESIGNING FORMS FOR DATA ENTRY

Select:

Category: Record Navigation

Action: Go to next record

Click Next.

You can choose to display either text or a picture on the button. In this
practical, we’ll use the default picture, but you can also browse and select
your own image if you have one.



405.0 DESIGNING FORMS FOR DATA ENTRY

Click Finish.

You can further customize the button’s font, size, and color using the

Format tab after placing it on the form.

Add a “Previous Record” Button
Repeat steps above but, but choose:

Action: Go to previous record

Picture : Go to previous

Add a “Close Form” Button
With the form still in Design View, click the Button tool again.

Place a new button below your navigation buttons.

In the wizard:

Category: Form Operations

Action: Close Form



415.0 DESIGNING FORMS FOR DATA ENTRY

Set the button to display the text “Close

Click Finish.

Arrange and Format the Buttons
Use the mouse to move buttons into a neat row or column.

Go to the Format tab to:

Align buttons using the Align group

Change font, color, or size for better readability



42

“Previous” goes back

“Next” moves to the next
student record 

“Close” close the form

5.0 DESIGNING FORMS FOR DATA ENTRY

STEP 5
Test Your Buttons

Switch to Form View (click View > Form View).

Click your buttons to check:



435.0 DESIGNING FORMS FOR DATA ENTRY

STEP 6 Change Form Colors and Fonts

Now, we will continue editing the form in Design View.

Go to the Form Design tab and use options like Theme Colors to apply a consistent

color palette. 



445.0 DESIGNING FORMS FOR DATA ENTRY

Alternatively, you can use the Shape Fill command in the Format tab to apply

colors to each section of your form

You can also add a background image to your form using the Background Image

command in the Format tab. 



455.0 DESIGNING FORMS FOR DATA ENTRY

STEP 7 Apply formatting

Format the Field Labels

Select all the field labels in the form. Then, use the Format tab to adjust the

font style, size and colours.

Edit the Label Text
Double-click each label to edit its text as follows:

Change Student_ID → Student ID

Change DOB → Date of Birth

Change Contact_Number → Contact Number



465.0 DESIGNING FORMS FOR DATA ENTRY

Adjust Text Alignment
Select all the text boxes in the form, and on the Format tab, set their text

alignment to Left. 

Switch to Form View to see the effect — all the data in the text boxes will

now be aligned to the left.

To add effects to your text boxes, select all the text boxes in the form. On the

Format tab of the Property Sheet, choose the Special Effect command, and

select any effect you like. 

STEP 8 Use Layout Tools for Alignment

Select multiple text boxes or labels.

Go to the Arrange tab.

Use Align or Size/Space options to make your layout more balanced and visually

neat.



47

Practice

5.0 DESIGNING FORMS FOR DATA ENTRY

Modify all your forms to make them more attractive.



485.0 DESIGNING FORMS FOR DATA ENTRY

5.4 Create a Main Menu Form 

A Main Menu Form serves as the central navigation hub for your

Microsoft Access database. It provides users with a simple, user-

friendly interface to access different parts of the system—such as

student records, reports, queries, and data entry forms—without

having to browse through the navigation pane.

Next, we'll create a Main Menu Form to provide easy access to all

other forms in the database.

1.  Go to Create > Blank Form.



5.0 DESIGNING FORMS FOR DATA ENTRY

 2. Add Buttons from the Controls tab for Students, Enrollment, and Grades Forms.

First, we will set the button to open the students form. Choose Open
Form action from Form Operations category.

49



5.0 DESIGNING FORMS FOR DATA ENTRY

 3. Set each button’s On Click event to Open Form and select the respective form.

4. Choose “Open the form and show all the records”.

50



6. Then, you can save the name for the button and click Finish.

5.0 DESIGNING FORMS FOR DATA ENTRY

5. Then, you can choose either text or picture on the button. In this practical, we will
choose text on the button.

51



Now your database has forms for adding students, enrolling them in courses, and
recording grades!

To set pop up for your Main Menu form, go to the property sheet and change pop
up to ‘yes’.

52

8. Repeat the steps to add buttons for Enrollment, and Grades Forms.

9. Save the form as Main Menu.

5.0 DESIGNING FORMS FOR DATA ENTRY

7. To test the button, right-click the form's tab and select Form View to open the

form, then click the button to see if it works.



Now your database has forms for adding students, enrolling them in courses,
and recording grades!

To set pop up for your Main Menu form, go to the property sheet and change
pop up to ‘yes’.

535.0 DESIGNING FORMS FOR DATA ENTRY

So, your Main Menu will be pop up every time you open the form



545.0 DESIGNING FORMS FOR DATA ENTRY

Example of the Main Menu form after modification

Practice

Modify your Main Menu form to make it more attractive.



Practice 1 : Data Entry

Use the form created to enter all the sample data given

for each table (Students, Courses, Enrollment, and

Grades)

Student
ID

Name DOB Gender Address
Contact
Number

Email

S001
Alia binti

Ali
1 Jan
2006

Female
40, Lorong Setia
1, Taman Setia,
21050 Kuantan

012-1234567 aliaali@gmail.com

S002
Bernard

Chandran
2 Feb
2006

Male
Lot 608, Kg

Bintang, 26500
Maran

014-1122334 bernard@gmail.com

S003
Hud bin
Hamzah

4
April
2006

Male

2, Lorong
Cempaka 2/2,

Taman Cempaka
Indah, 26070

Kuantan

017-
4455667

hud@gmail.com

S004
Mawar

binti
Yusof

5
May

2006
Female

No. 1, Kg
Sejahtera, 26600

Pekan

011-
7788990

mawar@gmail.com

555.0 DESIGNING FORMS FOR DATA ENTRY

STUDENTS



CourseID Course Name
Course
Code

Instructor

C01
Database

Fundamentals
SFC10393 Pn. Khairani binti Ibrahim

C02 English MPU1101 Sir Alex Fernadez

C03 Basic Mathematics SFC10343 En. Lutfi bin Hafiz

C04 Application Computer STM10462 Pn. Rahil binti Rafiq

StudentID CourseID Enrollment Date

S001 C01 2 Jan 2025

S002 C01 2 Jan 2025

S003 C03 4 Jan 2025

S004 C03 4 Jan 2025

StudentID CourseID Grade

S001 C01 85

S002 C01 70

S003 C03 90

S004 C03 75

565.0 DESIGNING FORMS FOR DATA ENTRY

COURSES

ENROLLMENT

GRADES



CHAPTER



Method 1: Using Query Wizard

57

2. In the New Query dialog box, select Simple Query Wizard and Click OK

6.0 WORKING WITH QUERIES

6.1 What are Queries?

Queries are used in Access to search, filter, and gather specific data from one or

more tables. Running a query is similar to asking a question to your database, where

you set certain conditions to retrieve only the information you need.

1.  Select Queries: Retrieving specific records

6.2 Creating Basic Queries

1.Go to the Create tab → Click Query wizard.

Creating a Select Query

Create a query to list all studentsEXAMPLE 1



58

3. Select Table: STUDENTS from Tables/Queries dropdown. Then, click right double
arrow (>>) to insert all available fields to the selected fields box and Click Next.

6.0 WORKING WITH QUERIES

4. Save the query → Name it: qryAllStudents and Click Finish



Your query will look like this

6.0 WORKING WITH QUERIES 59



Method 2: Using Query Design

3. Click Run (red exclamation mark).

6.0 WORKING WITH QUERIES

1.Go to the Create tab → Click Query Design.

2. In the Show Table dialog box, select Students table → Click Add → Click Close.
Double-click the following fields to add them to the grid:

StudentID

Name

DOB

Gender

Address

Contact_Number

Email

4. To save your query, click the Save button on the Quick Access Toolbar or right click on the

query’s tab > select Save. When prompted, enter a name for your query and then click OK.
In this practical, save the query  as qryAllStudents.
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EXAMPLE 2

616.0 WORKING WITH QUERIES

Click the link  to learn about the Query Design view

Create a query to list students and their grades

1.Go to the Create tab → Click Query Design.
2.In the Show Table dialog box, add all tables 



3. Double click the field names to add them to the grid:

StudentID and name from STUDENTS table
CourseID and CourseName from COURSES table
Grade from GRADES table

4. Click Run (red exclamation mark).

6.0 WORKING WITH QUERIES

5. Save the query → Name it: qryStudentsGrades 
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6.0 WORKING WITH QUERIES

Filter Queries: a mechanism to restrict the data returned by a query,

allowing you to focus on specific records or subsets of data that meet

certain criteria. 

Creating a Filter Query

Create a query to list all female students 

1. Go to the Create tab → Click Query Design.
2. In the Show Table dialog box, select Students table → Click Add → Click Close.
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3. Double click the field names to add them to the grid:

StudentID 

Name
Gender
Contact_Number

4. Type ‘female’ on criteria for Gender to filter female students.Typing the criteria

row will set your query to include only results that meet all the criteria. 

5. Click Run (red exclamation mark).

6. Save the query → Name it: qryFemaleStudents 
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To hide a field within a query:
In query design view, Click the checkbox in the Show row for Gender field to

uncheck it.

There may be situations where a field contains important criteria for

your query, but you don't necessarily need to display that field in the

final query results. 

For example, we want to create a query to list all female students

without showing the Gender field.

Access has hidden the Gender field while still applying the other criteria we

selected.

To display a hidden field again, go back to Design View and check the box in

the field's "Show" row.
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1. Go to the Create tab → Click Query Design.

2. Add Students table.

3. Double click the field names to add them to the grid:

StudentID 
Name
Contact_Number
Email 

676.0 WORKING WITH QUERIES

Parameter Queries: Allows you to create a query that prompts the user for

specific criteria when it's run, rather than having those criteria hardcoded

within the query itself. This enables you to reuse the same query structure

for different inputs without needing to modify the query's design. 

Creating a Parameter Query

Create a query to search Student by StudentID

6.3 Advanced Queries

4. In the Criteria row of the field that you want to apply a parameter to, enter the text

that you want to display in the parameter box, enclosed in square brackets. 

For example, In the Criteria row under StudentID , type: [Enter Student ID]
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5. Run the query → Enter a Student ID when prompted.

6. Save as: qrySearchStudentByID

Scan the marker to do exercise
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1. Create a select query to list all male students .

    (show Name, StudentID , Gender and Contact Number)

2. Create a parameter query to search the students grade by Course Code. 

    (show Name, StudentID, Course Name and Grade)

6.0

Practice 2

Your query should look like this:

1. Query to list all male students:

2.Parameter query to search the students grade by Course ID.
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2.Go to the Create Tab → Click Report.

7.0 GENERATING REPORTS

7.1 What are Reports?

7.2 Creating Reports Using the Report Command

1. Select the Students Table 

Creating a Student  List Report 

A report in Microsoft Access is a tool that helps you present data in a

clean, readable, and printable layout — perfect for printing results or

sharing summaries.Access allows you to generate reports using data from

both tables and queries.



717.0 GENERATING REPORTS

Your report is created and opened in Layout View. Some of your data may

appear beyond the page break. To resolve this, resize your fields by

selecting a field and dragging its edge to adjust the size. Repeat this

process for other fields until everything fits within the page.

To save your report, click the Save button on the Quick Access Toolbar or

right click on the report’s tab > select Save. When prompted, enter a name

for your report and then click OK.
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2. In the Tables/Queries drop-down, select:

   → Query: qryStudentsGrades 

3. Select a field  from the list on the left, and click the right arrow to add it to the report.

Or you can simply double click the field from the list on the left and it will be added to

the selected fields box. You can include fields from multiple tables or queries by

repeating the same steps.

5. Then click Next.

7.0 GENERATING REPORTS

7.3 Creating Reports Using the Report Wizard

Creating a Student Grade Report 

1. On the Create tab → Click Report Wizard.

4. For this example, select the fields below:

Student ID

Name

Course Name

Grade



747.0 GENERATING REPORTS

6. Click Next.

We will view our data by Course Name so students under the same course are

listed together.

Since our data is already listed by course name, there's no need to add

additional grouping levels. Just click Next.



757.0 GENERATING REPORTS

Next, we can determine the sort order of our records—up to four fields—in either

ascending or descending order. 

Click the top drop-down arrow and choose the first field you want to sort by. Then,       

to change the sort order, click the button on the right to select either ascending or  

descending. 

6. 

For this practical, choose the field ‘Name’ and set it to ascending order. 7.

Click Next.8.



767.0 GENERATING REPORTS

9. Next, we can choose the layout and orientation of our report. A preview of the

layout is shown on the left side. For this practical, choose the 'Outline' layout and

'Portrait' orientation.

10. Save your report and click finish.
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Your report is created and opened in Print Preview. 
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7.4 Customizing Reports

Let’s try it out!

Once you have created a basic report in Microsoft Access, the next step is

to customize it to meet your specific needs. Customization allows you to

control how your data looks and how easily others can understand it. In

this section, we will take a step-by-step approach to customizing reports.

You will learn how to switch to Design View, adjust the layout, modify fonts

and colors, insert images or logos, and fine-tune the organization of your

information. By following each step carefully, you will be able to create

professional-looking reports that are clear, organized, and visually

appealing.

In this practical, we will modify the Student Grade Report.

In the Navigation Pane, right-click your report.

Select Design View from the menu.

STEP 1 Open Report in Design View
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Drag and resize text boxes, labels, and other controls to better fit your data.

Drag the field borders left or right to resize.

Use the Arrange tab to align the fields neatly.

In this practical, resize the CourseName and Grade text boxes and Labels to make

them fit better.

STEP 2 Customize the Report Layout

You will now see the structure of the report, including sections like Report Header,
Page Header, Detail, and Footer.

STEP 3 Apply Formatting

Format the Field Labels
Select all the field labels in the report.

On the Format tab, set the font to Arial Bold and the font size to 12. 

Edit the Label Text
Double-click each label to edit its text as follows:

Change CourseName → Course Name

 Change Student_ID → Student ID

Adjust Text Alignment
Select the fields Name, Student ID, and Grade.

On the Format tab, set their text alignment to Center.
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Add Borders to Labels
Select the Name, Student ID, and Grade labels.

Go to the Format tab on the ribbon.

Click the Shape Outline command:

Choose the line type (such as solid or dashed) that you prefer.

Select the line color you want for the label borders.

Apply Fill Color to Labels
With the same labels still selected, click the Shape Fill command.

Choose a fill color to highlight the labels and make them stand out.
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PRACTICE

7.0 GENERATING REPORTS

Adjust the Font and Alignment of Text Boxes
Select the Student_ID and Grade text boxes (the actual boxes that display the

data, not the labels).

Go to the Format tab:
Change the font to Arial and the font size to 11. 

Set the text alignment to Center for better readability.

You can only adjust the font and alignment of these text boxes.

Do not change the content inside the text boxes — they are

linked directly to fields in your table. Editing the content could

break the connection to your data!

Editing the Report Title Label

Customize the Report Title

Locate the Report Title label in the Report Header section.

Click to select the label.

On the Format tab:

Change the font style (for example, to Arial Bold or another professional

font).

Adjust the font size to make the title stand out (for example, size 20 or

larger).

Set the text alignment to Center or Left, depending on your preferred

layout.

Move the title label to your desired position within the header to balance the

design.

Make sure the title is easy to read and properly centered (if required) to give

your report a polished, professional appearance.
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In Design View, click anywhere in the Report Header section (or another section

where you want to place the logo).

7.0 GENERATING REPORTS

STEP 4  Insert a Logo

You can align the logo with the report title or use the Arrange tab to ensure

consistent spacing and alignment across elements.

Optional Touch:

Go to the Design tab on the ribbon.

Click Logo 

A dialog box will appear — select your logo image file from your computer.

After inserting, resize the image by dragging the corners to fit neatly in the layout.

Move the logo into position — typically in the top-left or top-right corner of the header.
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Right-click in the report design and select Page Header/Footer if they are not

already visible.

STEP 5 Add Page Header and Footer

If you don’t see any white space in the Page Header or Page
Footer, don’t worry — it just means the section is currently

too small to display content.

To fix this, click and drag the bottom edge of the header or footer to

resize it. Once there’s enough space, you can easily insert text, page

numbers, or other elements.
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In the Page Header section, use Label to type custom information. e.g:  “Report

Date:”.

Then, use the "Date and Time" tool to insert the current date.

In the Page Footer section, use the Page Numbers tool from the Design tab to

insert page numbering in the format and position of your choice.

For this practical, first delete the existing text box in the footer.

Then, use the Page Numbers tool to insert new page numbering. Choose your

desired format, position, and alignment for the page number.



857.0 GENERATING REPORTS

Right click on the report tab and select Report View to see how your report looks

with the new labels, borders, and colors applied. 

STEP 6 Preview and Save the report

Make any small adjustments if necessary and save your report.

Check that:

The labels are easy to read.

The text is properly centered in the Name, Student ID, and Grade fields.

The colors and lines make the layout clearer without being too distracting.
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868.0 AUTOMATING YOUR DATABASE WITH
MACROS

In Microsoft Access, macros are powerful tools that let you

automate tasks and create interactive database systems—without

needing to write full-scale programming code. They act like scripts

or commands that tell Access what to do in response to events like

clicking a button or opening a form.

In the following steps, you'll learn how to create a macro that

enhances navigation in your system—automatically closing the
main menu and opening the student form when a button is
clicked. This simple but powerful feature is a great starting point

for introducing automation into your database.

Macros

automate tasks 
create interactive 
database systems



878.0 AUTOMATING YOUR DATABASE WITH
MACROS

8.1 Creating Simple Macros

When a user clicks a button (e.g., "Student Form") on the Main
Menu Form, Access should:

1.Close the Main Menu Form and

2.Open the Student Form 

STEP 1 Preview and Save the report

In the Navigation Pane, right-click on your Main Menu Form 

Select Design View.

STEP 2 Add Macro to the Button

Select the Student Form button.

In the Property Sheet, go to the Event tab.

Find the event labeled On Click.

Click inside the On Click field, then click the “...” (ellipsis button).



888.0 AUTOMATING YOUR DATABASE WITH
MACROS

Right click on the Student Form button.
Choose build event



898.0 AUTOMATING YOUR DATABASE WITH
MACROS

STEP 3 Define the Macro Actions

When creating the button, the Macro Builder automatically

includes the action to open the Student Form. We only need to

add an additional step to close the Main Menu Form.

To Close the Main Menu Form:
Add New Action

Choose Action: CloseWindow
Arguments:

Object Type: Form

Object Name: Main Menu (or whatever your main menu form is named)



908.0 AUTOMATING YOUR DATABASE WITH
MACROS

STEP 4 Save the Macro

Click Save on the toolbar.

Close the Macro Builder.

STEP 5 Test the Macro

Switch the form to Form View.

Click the button.

It should:

Close the Main Menu Form
Open the Student Form

MACRO MAIN MENU



918.0 AUTOMATING YOUR DATABASE WITH
MACROS

Add a button to the Student Form that opens the Main Menu

Form and closes the Student Form when clicked.

Practice 
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929.0 CONCLUSION

By following this step-by-step guide, you have successfully created a functional

database system using Microsoft Access. You now have the foundational skills to

build and customize databases for various applications. 

With continued practice, you can explore more advanced features to enhance

your database systems.
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