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DEVELOP MOBILE APPS USING ADOBE ANIMATE CC 2020 
 

INTRODUCTION 
 

Adobe Flash was replaced with Adobe Animate due to increasing popularity of better 

technologies like HTML5 and bad press from internet basically everyone on internet and 

added several new features so that we can export our animations in more format include 

HTML 5.  Now, there is a Cross Platform Technology called Adobe AIR that allows to 

make apps and games within Animate for several operating systems including Android 

and IOS.  Creative Cloud is a collection of 20+ desktop and mobile apps and services for 

photography, design, video, web, UX and more.  
 

 

NEW FEATURES ADOBE ANIMATE 2020 
 

a) Auto Keyframe 

In the latest release, you can insert Keyframe or Blank keyframe automatically. The Auto 

keyframe option adds Keyframe or Blank Keyframe to the selected frame while editing the 

stage or the Properties panel. A blue dot appears outside the existing frame range to indicate 

the frame number for auto-keyframing. 

 
 

b)  Assets Panel 

The latest version of Animate introduces Assets panel to store, manage, and reuse ready-to-

use assets across documents. From the Context Menu in Library panel, you can export any 

image or symbol as an asset. Once exported, you can import assets into the Assets panel from 

the Hamburger Menu> Import. 
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c) Quick Social Share 

The latest update allows you to quickly share your animations on Twitter. To share your 

content on Twitter, click the Share button> Quick social share>Twitter. Check the preview, 

type your tweet, and click Share to generate a video via Adobe Media Encoder and post it. 

 

 
 

d) Hands-on Tutorial Creator 

Eager to create your own hands-on tutorial.  You can quickly create hands-on tutorial using 

the new panel from Window> Extensions> Hands-on Tutorial Creator menu. The panel 

allows you to create a new or edit an existing tutorial.  

 

 
 

Once saved, you can test it out by importing it using Help> Hands-on Tutorial> Import 

Tutorial. 

 

For new users to get started, animate allows you to explore hands-on tutorials of your choice. 

You can hover over the tutorial to watch the preview or skip the panel to explore later. 
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e) New User On-Boarding Panel  

 

 
 

 

f) Selective Texture Publishing 

To speed up Canvas publishing and reduce output file size, a new optimization is in place 

when Export as: Texture is selected in Publish settings. The optimization selectively 

converts complex vector shapes to bitmaps and retains simple shapes as vector. Also, the 

optimization ensures that runtime performance remains uninterrupted. 

 

https://helpx.adobe.com/animate/using/whats-new.html 

https://www.youtube.com/watch?v=7W0ISI3yqwo 

 

 

ACTIONSCRIPT 3.0 

 

ActionScript 3.0 is a powerful, object-oriented programming language that signifies an 

important step in the evolution of the capabilities of the Flash Player runtime. 

 

 

 

  

https://helpx.adobe.com/animate/using/whats-new.html
https://www.youtube.com/watch?v=7W0ISI3yqwo
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STEPS ON HOW TO DEVELOP MOBILE APPS  

 

SECTION A: PREPARING STORYBOARD 
 

A storyboard is a graphic layout that sequences illustrations and images with the purpose of 

visually telling a story. A story board is used to communicate how a scene or frame will play 

out scene by scene or frame by frame.  Storyboard panels can be comprised of custom 

drawings including type of buttons either image button or creating button from box and text 

convert to image, screenshots from comparable notes, photos or videos. 

Example Storyboard Template: 

 

 

 

 

 

SCENE 1: FRONT PAGE – No Background 
Image 

 
 

 

 

 

 

                                                                                                                                 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

MOBILE APPS USING  

ADOBE ANIMATE CC 2020 

SCENE 2: MENU PAGE – Background Image 
Electric Circuit 

 

                                                     

 

 

 

                                                                

 

 

 

                                                                                                                                   

 

 

 

 

 

 

 

 

 

 

 

 

 

MENU   
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SCENE 6: SUB-CHAPTER 1 (FEATURES) – No 
Background Image 

 

                                  

                    

 

 

 

 

 

 

 

 
 

                       

    

                                                                                                                                   

 

 

 

 

 

 

 

FEATURES 

a) Auto Keyframe 

In the latest release, you can insert Keyframe or Blank 

keyframe automatically. The Auto keyframe option 

adds Keyframe or Blank Keyframe to the selected 

frame while editing the stage or the Properties panel. A 

blue dot appears outside the existing frame range to 

indicate the frame number for auto-keyframing. 

 

SCENE 5: SUB-CHAPTER 1 (INTRODUCTION) 
– No Background Image 

 
                                                     

 

 

 

 

 

 

 

 

 

 

                       

    

                                                                                                                                   

 

 

 

 

 

 

 

1.0 INTRODUCTION TO ADOBE ANIMATE CC 2020 

 

Adobe Flash was replaced with Adobe Animate due to 

increasing popularity of better technologies like HTML5 

and bad press from internet basically everyone on 

internet and added several new features so that we can 

export our animations in more format include HTML 5.   

INTRODUCTION 
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SECTION B: PREPARING INTERFACE 

1. On Creative Cloud Desktop -> Open Animate (An) software.  

 

 
 

 

2. Popup menu Adobe Animate CC 2020 appear as below. Click Create New. 
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3. Menu New Document appear -> Select Education.  Then at Tab PRESETS (15) -> 

Select Android 16:9 (1280 x 720) and change Platform Type to ActionScript 3.0 -> 

Then click Create.   

** We can select any size of PRESETS depends on our target apps we want to produce.  

There are 15 template that we can choose. 
 

 
 

4. The popup Scene will appear as below.  Set the stage as Fit in Window, so that the stage 

doesn’t moving up and down when we scroll up and down mouse @ cursor.  The purpose 

is to lock the moving of the stage so that design process easier.   

 

 

Stage 
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5. Otherwise we can create a New Scene from Tab File -> New -> Select Education.  Then 

at Tab PRESETS (15) -> Select Android 16:9 (1280 x 720) and change Platform Type 

to ActionScript 3.0 -> Then click Create.  

 

 

   

6. Then Create LAYER (at least 4) by click button +.  Then RENAME the layer by double 

click the default name of layer (eg. Layer 4: Graphic; Layer 3: Text; Layer 2: Button; 

Layer 1: BG)  

 

 

 Frame 1 

Timeline 

Layer 1 
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7. At Tap Properties -> Documents Settings -> Change Stage Size to W = 720 and H = 

1280 to get apps display in Portrait Size.  Then click Tab File -> Save As -> File Name: 

______.  This file was saved as type Animate Document (*.fla). 

 

** Make sure all the files @ works keep in one folder – (e.g: Mobile Apps) 
 

 
 

8. At Layer Graphic, import a picture to Frame 1. Select File -> Import -> Import to 

Stage (select any picture from your desktop, for example - a polytechnic logo).  Resize 

your picture using Free Transform Tool.   
 

@ File -> Import -> Import to Library (to keep image in the library). 
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Selection Tool Sub Selection Tool Free Transform Tool 

To select object To move the direction points 

to reshape the curves. 

To scale, rotate, or skew a 

selection 
 

https://helpx.adobe.com/animate/using/basic-tools.html 
 

 
 

9. In the same frame at Layer BG, insert Background. 

Google -> Pastel Background -> Images -> Select image (no watermark) -> Save at 

Location where we save an Adobe Animate CC 2020 -> File -> Import -> Import to 

Library -> Then from Library Drag to Stage -> Then at Tab Properties -> at Tab 

Object setup the Position and Size as below: 

Click once on the stage at Layer Graphic, and import 
graphic into stage @ drag the logo from Library  

https://helpx.adobe.com/animate/using/basic-tools.html
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X:  0.00        Y:  0.00 

              W: 720.00   H: 1280.00 

 
 

10. In the same frame at Layer Text, insert Text using Text Tool. Select Text tool, then 

click once on the area we need to put a text ….. and type the text!  Align your text and 

picture using Align Tool. 
 

 
 

11. In Layer Button, create a rectangular shape. This rectangular shape is used as a Button. 
 

1. Select Text Tool 

2. Click once on the stage, and type the Text 

3.  Align text to horizontal 

centre 
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12. Colour the Button. Here, you can set Fill and/or the Stroke (which is line) colour. 
 

 
 

 

 

 

 

1. Select Rectangle 
Primitive Tool 

1. Select Stroke (box 
line) & Fill Color 

3. Adjust the rectangular 
shape by drag this point to 
left or right  

2. Click on the stage to 
create the rectangular  

2. Click once inside 
the rectangular 

Fill and Stroke 
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13. Insert text into the button and design your first interface apps. 
 

 
  

14. Click Free Transform Tool to select Button and Text to convert as a button.  Right 

click mouse -> Select Convert to Symbol or F8.  Popup menu Convert to Symbol 

appear as below: 
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15. Popup menu Convert to Symbol appear as below.  Then rename the Symbol 1 (default) 

for example Btn1 and change button Type as Button.  Then click OK. 
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16. Then rename the Button Properties same as Symbol Name for example Btn1.  
 

 
 

17. The created button Btn1 appear at Library.  
 

 
 

 

 

  

Button 
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SECTION C: CREATE AN ANOTHER SCENE 

 

1. To add another Scene, click Window Tab -> Scene or Shift+F2.  This action will create 

a second scene for another page interface in mobile apps.  
 

 
 

 

2. Popup menu Scene appear then click button + to add another scene.   
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3. Then rename the Scene 1 as Home and Scene 2 as Menu by double click the scene 

picture. 
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4. In Scene 2 stage, insert an information about Menu page.  Design the stage by follow 

the raw idea in storyboard including all the button.  The button will be used as link to 

connect between scene. 
 

 
 

5. Import all the images that will be used in this mobile apps design to the library. The 

button image very important because it’s will be used as link to connect between scene. 
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SECTION D: HOW TO CREATE MULTIPLE BUTTON  

 

1. Multiple button can be created in one interface paged or Scene.  Create one button and 

rename for example ChapterBtn1 button. 
 

 

 

2. Click the button on the stage and then right click mouse -> select Copy -> then Paste 

in Center.   
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3. Click the second button name Chapter 1 again then right click mouse -> select Break 

Apart to change wording in second button another word for example Chapter 2 (refer 

storyboard).   
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4. We can change the colour of wording into different colour at Character Tab -> Color.   
 

 
 

5. Then convert and rename second button Chapter 2 into button.   
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6. We also can transfer our multiple button to another scene.  Add another scene rename 

the scene for example Chapter 1 and then select which button we want to transfer for 

example button Chapter 3 then cut and paste into another scene.   
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7. There two options paste which Paste, which is Paste in Center and Paste  in Place.   
 

 
 

8. Paste in Center mean the button will put at the center of the stage.   
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9. Mean while Paste in Place mean the button will put at the same position same as previous 

scene where it is. 
 

 
 

10. The deleted button still save and appear in Library, so we can drag the button for example 

button Chapter 3 and place it in the new scene for the example scene Chapter 1. 
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11. Button also can copy as a group by select the button that request to copy for example 

button home and button menu in scene Notes Content to scene Chapter 1 using Free 

Transform Tools (Q).  Right click mouse -> select Copy.  
 

 

 

12. Click the requested scene which is scene Chapter 1.  Then Right click mouse -> then 

Paste in Place. 
 

 

 

13. Then changes the name of button by right click mouse -> Duplicate the Symbol. Then 

change MenuBtn1 copy to MenuBtn2 -> click OK.  The new name of the button will 

appear at Object Tab as Instance of: MenuBtn2.  Then we change Instance Name same 
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as button name MenuBtn2.  Repeat the process for all button that we copy @ duplicate 

(refer storyboard). 
 

 

 

14. Then change MenuBtn1 copy to MenuBtn2 -> click OK.  The changes Instance of: 

MenuBtn1 to MenuBtn2 and also changes    

 

 

 

15. The new name of the button will appear at Object Tab as Instance of: MenuBtn2.  Then 

we change Instance Name same as button name MenuBtn2.  Repeat the process for all 

button that we copy @ duplicate (refer storyboard). 
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16. Size of the button can also resize in a group.  Click Free Transform Tools (Q) -> select 

all the button -> Then resize size of the button. 
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17. All the contents of the scene (graphic, text, button also background) can be copy using 

Duplicate Scene in the Scene Tab.  For example, we duplicate scene Introduction.  Then 

we get copy of the Introduction scene -> Introduction copy.   
 

 

 

18. Then rename the copy of the scene for example Features (refer to storyboard).   
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19. Notes write on the scene can be select from word file or power point also from web.  Just 

select and paste it after we active the Text Tools (T).  Make sure the text that we wat 

wrote is in Text layer.   
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SECTION E: MAKE A CONNECTION BETWEEN SCENES 

 

1. Click one of the buttons for example enter button (EnterBtn1).  
 

 
 

2. Click icon Windows and select Actions @ F9. 
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3. Click the button -> Click Code Snippet, and then select Timeline Navigation -> Stop at 

this Frame. 
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4. The purpose to select Stop at this Frame to stops the playhead from advancing to the 

next frame in the Timeline @ the scene is flashing and doesn’t work. 
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3. Then, to make a connection to the other scene or interface, click again the button. Select 

Timeline Navigation -> Click to Go to Scene and Play.  You ONLY need to change 

the name of scene. 
 

 
 

Scene: Home 

/* Stop at This Frame 

The Animate timeline will stop/pause at the frame where you insert this code. 

Can also be used to stop/pause the timeline of movieclips. 

*/ 

 

stop(); 

 

/* Click to Go to Next Scene and Play 

Clicking on the specified symbol instance moves the playhead to the next scene in the timeline 

and continues playback in that scene. 

*/ 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

EnterBtn1.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene); 

 

function fl_ClickToGoToScene(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Menu"); 

} 
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ExitBtn1.addEventListener(MouseEvent.CLICK, fl_ClickToGoToWebPage); 

 

function fl_ClickToGoToWebPage(event:MouseEvent):void 

{ 

 NativeApplication.nativeApplication.exit(0); 

} 

 

 

Scene: Menu 

/* Stop at This Frame 

The Animate timeline will stop/pause at the frame where you insert this code. 

Can also be used to stop/pause the timeline of movieclips. 

*/ 

 

stop(); 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

HomeBtn.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_1); 

 

function fl_ClickToGoToScene_1(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Home"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

NotesBtn.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_3); 

 

function fl_ClickToGoToScene_3(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Notes Content"); 

} 
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Scene: Notes Content 

/* Stop at This Frame 

The Animate timeline will stop/pause at the frame where you insert this code. 

Can also be used to stop/pause the timeline of movieclips. 

*/ 

 

stop(); 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

HomeBtn1.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_4); 

 

function fl_ClickToGoToScene_4(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Home"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

MenuBtn1.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_5); 

 

function fl_ClickToGoToScene_5(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Menu"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

ChapterBtn1.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_6); 

 

function fl_ClickToGoToScene_6(event:MouseEvent):void 

{ 
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 MovieClip(this.root).gotoAndPlay(1, "Chapter 1"); 

} 

 

Scene: Chapter 1 

/* Stop at This Frame 

The Animate timeline will stop/pause at the frame where you insert this code. 

Can also be used to stop/pause the timeline of movieclips. 

*/ 

 

stop(); 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

HomeBtn2.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_7); 

 

function fl_ClickToGoToScene_7(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Home"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

MenuBtn2.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_8); 

 

function fl_ClickToGoToScene_8(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Menu"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

IntroBtn.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_9); 

 

function fl_ClickToGoToScene_9(event:MouseEvent):void 
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{ 

 MovieClip(this.root).gotoAndPlay(1, "Introduction"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

FeaturesBtn.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_10); 

 

function fl_ClickToGoToScene_10(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Features"); 

} 

 

Scene: Introduction 

 

/* Stop at This Frame 

The Animate timeline will stop/pause at the frame where you insert this code. 

Can also be used to stop/pause the timeline of movieclips. 

*/ 

 

stop(); 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

HomeBtn2.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_11); 

 

function fl_ClickToGoToScene_11(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Home"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

MenuBtn2.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_12); 
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function fl_ClickToGoToScene_12(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Menu"); 

} 

 

/* Click to Go to Next Scene and Play 

Clicking on the specified symbol instance moves the playhead to the next scene in the timeline 

and continues playback in that scene. 

*/ 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

NextBtn1.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_13); 

 

function fl_ClickToGoToScene_13(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Features"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

BackBtn1.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_14); 

 

function fl_ClickToGoToScene_14(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Chapter 1"); 

} 

 

Scene: Features 

 

/* Stop at This Frame 

The Animate timeline will stop/pause at the frame where you insert this code. 

Can also be used to stop/pause the timeline of movieclips. 

*/ 

 

stop(); 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 



CREATE ANDROID MOBILE APP LESS THAN AN HOUR USING ADOBE ANIMATE CC 2020 

 

40 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

HomeBtn3.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_15); 

 

function fl_ClickToGoToScene_15(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Home"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

MenuBtn3.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_16); 

 

function fl_ClickToGoToScene_16(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Menu"); 

} 

 

/* Click to Go to Scene and Play 

Clicking on the specified symbol instance plays the movie from the specified scene and frame. 

 

Instructions: 

1. Replace "Scene 3" with the name of the scene you would like play. 

2. Replace 1 with the frame number you would like the movie to play from in the specified 

scene. 

*/ 

 

BackBtn2.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene_17); 

 

function fl_ClickToGoToScene_17(event:MouseEvent):void 

{ 

 MovieClip(this.root).gotoAndPlay(1, "Introduction"); 

} 
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SECTION F: CREATE LINK WITH ONLINE FEATURES (WEBSITE) 

1. Button also can link into online features for example Socrative @ Flexi Quiz Link @ 

other quiz platform.  Click the Quiz button -> Click Code Snippet, and then select 

Actions -> Click to Go to Web Page. 
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2. Then change the URL http://www.adobe.com into URL of Socrative room for student 

“https://b.socrative.com/login/student/” 

 

  

http://www.adobe.com/
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/* Click to Go to Web Page 

Clicking on the specified symbol instance loads the URL in a new browser window. 

 

Instructions: 

1. Replace http://www.adobe.com with the desired URL address. 

   Keep the quotation marks (""). 

*/ 

QuizBtn.addEventListener(MouseEvent.CLICK, fl_ClickToGoToWebPage_2); 

 

function fl_ClickToGoToWebPage_2(event:MouseEvent):void 

{ 

 navigateToURL(newURLRequest("https://b.socrative.com/login/student/"), 

"_blank"); 

} 

 

3. Click the VIDEO button -> Click Code Snippet, and then select Actions -> Click to 

Go to Web Page.  Change the URL http://www.adobe.com into URL of YouTube link 

for example link of video about Intro to Adobe Animate 2020 [1/4] Beginners Tutorial  

“https://www.youtube.com/watch?v=7huMYp7WpsI” 

 

 
 

/* Click to Go to Web Page 

Clicking on the specified symbol instance loads the URL in a new browser window. 

 

Instructions: 

1. Replace http://www.adobe.com with the desired URL address. 

   Keep the quotation marks (""). 

*/ 

VideoBtn.addEventListener(MouseEvent.CLICK, fl_ClickToGoToWebPage_3); 

 

function fl_ClickToGoToWebPage_3(event:MouseEvent):void 

{ 

 navigateToURL(newURLRequest("https://www.youtube.com/watch?v=7huMYp7

WpsI"), "_blank"); 

} 

http://www.adobe.com/
https://www.youtube.com/watch?v=7huMYp7WpsI
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SECTION G: ATTACH .apk FILE TO ADOBE FOLDER 
 

1. Adobe AIR is a cross-platform runtime system developed by Adobe Systems for building 

desktop applications and mobile applications, programmed using Adobe Animate, 

ActionScript and optionally Apache Flex.  The free Adobe AIR SDK provides a set of 

command line tools for packaging AIR applications. The SDK can be used with any text 

editor to build and deploy an AIR application. Starting version 20.0.2, AIR SDK is no 

longer shipped with Animate to optimize and installation experience.  But the latest 

version still can be downloading from Adobe or Harman website.   
 

2. Open Google Platform then type AIR SDK HARMAN -> https://airsdk.harman.com/ 

 

 

 

3. Click downloads then tick the checkbox I accept the terms of the AIR SDK Licence 

Agreement. 
 

 

https://airsdk.harman.com/


CREATE ANDROID MOBILE APP LESS THAN AN HOUR USING ADOBE ANIMATE CC 2020 

 

45 

4. Then select AIR SDK for Windows – (33.1.1.190).  This is the latest version for 64-bit 

ARM processor.  Starting 2019, almost apps running on Android and IOS must support 

64-bit.   

https://airsdk.harman.com/download 

 

 

5. We can get SDK FILE  

 
 

6. Adobe AIR SDK and compiler can also download from Adobe official website ->  

https://www.adobe.com/devnet/air/air-sdk-download.html. Then select Windows to 

download AIR SDK_Windows.  This is for handphone and Windows and Mac that 

support 32-bit processor.  

 

 

https://airsdk.harman.com/download
https://www.adobe.com/devnet/air/air-sdk-download.html
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7. Create a new folder and rename the folder AIRSDK_Windows for 33.1.1.190 and 

AIRSDK_Compiler for 32.0.0.116 at location where Adobe Animate CC 2020 inside.  

Extract the downloaded SDK File from Downloads Folder into the folder. 
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8. Then in Animate, select Help -> Manage Adobe AIR SDK -> then click button + at 

popup menu to Add New SDK button -> then search folder AIRSDK_Windows for 

33.1.1.190 and AIRSDK_Compiler for 32.0.0.116 at location where Adobe Animate 

CC 2020 (don’t double click) -> then click OK. 
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SECTION H: CREATE ICON AND SETUP IMAGE SIZE DISPLAYED FOR 

MOBILE APPS  
 

1. Find or search image from Google (that suit with our task) and Save As in .PNG.  Then 

OPEN in PAINTS.  Select the image then Crop the image and Save As – Crop 

Image.PNG.   
 

 
 

 

2. Original Size of the image after Crop is 947 x 561 px.   
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3. Set the image pixel to 255x255.  Click Resize Tabs -> then Untick Maintain aspect 

ratio -> then click Pixels -> then change the size as 255 x 255.  Save as 255.PNG. 
 

 

 

4. Use the image with the size 255 x 255 as main image to resize to 36 x 36, 48 x 48, 72 x 

72, 96 x 96, 144 x 144 and 192 x 192. 
 

 

 

 

 

Original Size (255 x 255) 
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5. Then click Resize Tabs -> then Untick Maintain aspect ratio -> then click Pixels -> 

then change the size as 36 x 36.  Save as 36.PNG.  
 

 

 

 

6. Open again the image size 255 x 255 -> then click Resize Tabs -> Untick Maintain 

aspect ratio -> then click Pixels -> then change the size as 48 x 48.  Save as 48.PNG.   
 

Save As Type in .PNG 
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7. Do for another size 48 x 48, 72 x 72, 96 x 96, 144 x 144 and 192 x 192.  Make sure all 

the images put in one folder and in the same folder of your flash file and also in .PNG 

type. 
 

 

 

 

Change Size to (48 x 48) 
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SECTION I: PUBLISH THE FLASH FILE TO ANDROID FILE FORMAT (.apk) 

 

1. Click File Tab -> then select Publish Settings -> in Target tab, please choose AIR 

33.3.3.1 for Android.  
 

 
 

              

 
 

 

  



CREATE ANDROID MOBILE APP LESS THAN AN HOUR USING ADOBE ANIMATE CC 2020 

 

54 

2. Then tick select type of output file to be publish -> Flash (.swf), HTML Wrapper and 

Win Projector (so the output can be play in computer as flash file)  
 

 
 

 

3. In General tab, set as below.  At Output File, browse file name with .apk, for example 

Develop Mobile Apps4.apk. 
 

 

1 

2 
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The generate output file 
same as name of .fla file 
Develop Mobile Apps 4 

But we can change the name to 
MyEasyApps.apk.  This is the name 
be appear with our apps icon after 
publish. 

1 

2 

Tick Full Screen so that display appear in 
handphone is in Full Screen.  

Select ARMv8 (64 bit)  

3 

4 
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4. In Deployment tab, set as below. Create the certificate. Save the certificate in the 

same folder of your flash file. 

 

 
 

 

 

 

 

Fill up all the information to 
creating certificate for 
publishing purpose (.apk). 

3 

2 

4 

1 
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5 

Retype password that we 
created in step 2 

6 
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5. Setup your apps icon image display in different size depends on your smart phone size 

screen in Icons Tab.   

 

 
 

6. Before we setup the apps icon image displayed, we need to build the icon image in size 

36x36, size 48x48, size 96x96, size 144x144 and size 192x192.  Steps how to create the 

different size of apps icon image displayed was explain at Section H. 

 

7. In Permissions Tab, tick check box Internet as a permission during run our apps. 
 

 

 

  

Open the folder that we save 
all the app image and click 
the image one by one until 
all the image display here 
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8. In Language Tab -> select English as supported languages. 
  

 
 

9. Click Publish. This will create your apps in .apk file format. Transfer the file into your 

smartphone (Android OS) then install the that .apk file and enjoy the apps. 
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SECTION J: HOW TO INSTALL .APK FILE INTO ANDROID PHONE   

 

1. Copy the .APK file that we created for example MyEasyApps.apk from folder where 

the is saved -> send to target user via email or WhatsApp’s -> click the 

MyEasyApps.apk file.  

 

 

 

2. Click Install when the popup below appears.  If the file can,t be installed and required 

APK Installer, so we need to download it from PlayStore. 

 

 

 

 
  

1 

2 
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3. Installing process Done. 

 

 

 

 

 

4. Click Done or Open then the MyEasyApps ready to use. 

 

 

 

3 

4 

5 
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5. The mobile apps that we created also can upload to Google Play with one-time payment 

for creating account as developer to Android.  After register as developer we can upload 

any .APK apps created through this link https://www.easyeasyapps.net/en/how-to-

publish-app-tutorials/how-to-publish-app-on-google-play/ 

 

  

6 

https://www.easyeasyapps.net/en/how-to-publish-app-tutorials/how-to-publish-app-on-google-play/
https://www.easyeasyapps.net/en/how-to-publish-app-tutorials/how-to-publish-app-on-google-play/
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SECTION K: FOLDER AND FILE CREATED WHEN RUN ADOBE ANIMATE CC 

SOFTWARE   

 

1. All our work will save and display in the same folder where we save our Adobe Animate 

CC software the we created before we start as shown below.  In the folder will contents: 

 

a. Fla File (.fla) - An Animate file that allow we to continue the works. 

b. License file (.p12) – License file that allow we install in our Android mobile phone. 

c. APK File (.apk) – File create after Publish our storyboard (flow of work). This is the 

file that we install in our Android mobile phone. 

d. Flash File (.exe) – Another file create after Publish (Application file) and can play in 

our computer. 
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SECTION L: HOW TO CONTINUE AFTER CLOSING SOFTWARE @ AFTER 

PUBLISH 

 

1. After we click and open Animate from Adobe Creative Cloud software, click Open Tab 

and select .fla file from folder that we saved our work before for example Develop Mobile 

Apps 4.   
 

 
 

 
 

  

Open FileName.fla 



CREATE ANDROID MOBILE APP LESS THAN AN HOUR USING ADOBE ANIMATE CC 2020 

 

65 

2. Then we just add New Scene or just add New Frame to continue previous work 

eventhough that file already publish.  We just need to republish again for the updating 

information or just publish as a new .APK file with new identity. 
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Feel the Augmented Reality experience!  Take your smartphone and scan the logo below 

using the Blippar app to access the VIDEOS inside. 

Set the Test Code in the app setting to 1587523 to access the content. 
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